F-Secure Freedome for Business (for Android)

  • Supported devices: Android smartphones and tablets using Android 5.0 or later
  • Supported operating systems: Android 5.0 or later
  • Supported languages: English, Traditional Chinese (Hong Kong), Czech, Danish, Dutch, Finnish, Canadian French, French, German, Hungarian, Italian, Japanese, Korean, Norwegian, Polish, Brazilian Portuguese, Portuguese, Russian, Spanish, Swedish

F-Secure Freedome for Business (for iOS)

  • Supported devices: Apple iPhone and iPad devices running iOS 9.0 or later
  • Supported operating systems: Apple iOS 9.x or later
  • Supported languages: English, Traditional Chinese (Hong Kong), Czech, Danish, Dutch, Finnish, Canadian French, French, German, Japanese, Korean, Norwegian, Spanish, Swedish

F-Secure Mobile Security (for Android)

  • Supported devices: Android smartphones and tablets using Android 5.0 - 9.0
  • Supported operating systems: Android 5.0 – 9.0
  • Supported languages: English, Bulgarian, Simplified Chinese (People's republic of China), Traditional Chinese (Taiwan), Traditional Chinese (Hong Kong), Croatian, Czech, Danish, Dutch, Finnish, French, German, Greek, Hungarian, Indonesia, Italian, Japanese, Korean, Malay, Norwegian, Polish, Brazilian Portuguese, Portuguese, Romanian, Russian, Slovenian, Spanish, Spanish (Latin American), Swedish, Tagalog, Thai, Turkish

show all